Fidonet Portal






From: Aaron Grasswell (3:770/100)
To: All
Date: Fri, 12.02.21 21:58
RemoteAccess with D'Bridge
Hi Everyone,

I have a strange (most likely caused by me) issue with D'Bridge not picking
up echomail written by users on my BBS.

I run RemoteAccess (running in a DOS session in Windows) and D'Bridge
(running simultaneously in another DOS session).

I can receive echo/netmail no problem. D'Bridge routes the messages into
RA's messagebase without any issue.
But if I write a message in an echo area from within RA, DB doesn't see the
message, even thought the dbridge.rse or .rsn files are created (I can see DB
checking when the .rs* files are created, but no echomail is found/send on
it's merry way).

I can "force" DB to send netmail written in RA by using MBUTIL and extracting
the *.MSG mail file from RA's netmail area and putting it into DB's Netmail
directory.

I also find, if I set DB's directory path for netmail storage to be QuickBBS
(area 100, which it is in RA) instead of Fido, I can no longer access netmail
within DB (if I try, DB hangs with a perpetual "wait...").
But if I leave it as Fido, I can acces netmail within DB just nothing gets
injected into RA's netmail.

Has anyone else who runs/ran RA and DB ever seen something like this?
I hope that all made sense. lol

I'd also like to say thanks Nto ick for all your help and suggestions!
Learning lots! Smile

Cheers
everyone.
Take care
Aaron/DW
Dark Systems BBS
bbs.dsbbs.ca:23

--- Mystic BBS v1.12 A46 2020/08/26 (Windows/32)
* Origin: Agency BBS | Dunedin, New Zealand | agency.bbs.nz (3:770/100)

From: Nick Andre (1:229/426)
To: All
Date: Sat, 13.02.21 02:37
Re: RemoteAccess with D'Bridge
On 13 Feb 21 09:22:00, Aaron Grasswell said the following to All:

AG> I have a strange (most likely caused by me) issue with D'Bridge not picking
AG> up echomail written by users on my BBS.
AG>
AG> I run RemoteAccess (running in a DOS session in Windows) and D'Bridge
AG> (running simultaneously in another DOS session).

This may be a record-locking problem with the message database. Please try
writing a message from RA with the D'Bridge instance shutdown. Then shutdown
RA and run D'Bridge and scan the Echobase. Let me know what happens.

Nick

--- Renegade vY2Ka2
* Origin: Joey, do you like movies about gladiators? (1:229/426)

From: Aaron Grasswell (3:770/100)
To: All
Date: Sat, 13.02.21 16:01
Re: RemoteAccess with D'Bridge
Hi Nick,

Thanks for the suggestion.
I tried several messages in several different echo areas across several
different nets with DB not running, but none sent when I loaded DB after and
forced mail / created the.rse.

The weird thing is, every so often I'll see a
"got it" reply to one of my test messages, but I have no idea how/when it sent
and why 99.999% of the other messages I try don't send. lol

I do appreciate your help!
Aaron

--- Mystic BBS v1.12 A46 2020/08/26 (Windows/32)
* Origin: Agency BBS | Dunedin, New Zealand | agency.bbs.nz (3:770/100)

ABOUT

This forum contains echomail areas hosted on Nightmare BBS You can browse local echomail areas, italian fidonet areas and a selection of international fidonet areas, reading messages posted by users in Nightmare BBS or even other BBSs all over the world. You can find file areas too (functional to fidonet technology). You can browse echomail areas and download files with no registration, but if you want to write messages in echomail areas, or use fidonet netmail (private messages with fidomet technology), you have to register. Only a minimal set of data is required, functional to echomail and netmail usage (name, password, email); a registration and login with facebook is provided too, to allow easy registration. If you won't follow rules (each echomail areas has its own, regularly posted in the echomail), your account may be suspended;

CONTACT